Showing posts with label Networking. Show all posts
Showing posts with label Networking. Show all posts
Objective Questions on Application Layer in OSI/TCP/IP Model set-3

Objective Questions on Application Layer in OSI/TCP/IP Model set-3


1) In a/an ........... of DNS resolver, instead of supplying a name and asking for an IP address, the DNS client provides the IP address and requests the corresponding host name.

A. Recursive queries

B. Iterative queries

C. Reverse queries

D. Inverse queries


2) For each resolved query, the DNS resolver caches the returned information for a time that is specified in each resource record in the DNS response. This is known as .........

A. Positive caching

B. Time To Live

C. Negative Caching

D. Reverse Caching


3) As originally defined in RFC 1134, .............. negative caching is the caching of failed name resolutions.

A. Positive caching

B. Time To Live

C. Negative Caching

D. Round Robin Load Balancing


4) ............... can reduce response times for names that DNS cannot resolve for both the DNS client and DNS servers during an iterative query process.

A. Positive caching

B. Time To Live

C. Negative Caching

D. Round Robin Load Balancing


5) The amount of time in seconds to cache the record data is referred to as the .........

A. Time To Cache

B. Time To Live

C. Time For Record

D. Time To Save


6) Which of the following issues arises, when multiple resource records for the same resource record type exist.

A. For the DNS server, how to order the resource records in the DNS Name Query Response message.

B. For the DNS client, how to choose a specific resource record in the DNS Name Query Response message.

C. Both of the above

D. None of the above.


7) To address the issues arises when multiple resource records for the same resource record type exist, RFC 1794 describes a mechanism named ................. to share and distribute loads for network resources.

A. Positive caching

B. Time To Live

C. Negative Caching

D. Round Robin Load Balancing


8) A ............ gets the data for its zones from locally stored and maintained files.

A. primary name server

B. secondary name server

C. ternary name server

D. primary name client


9) A ............. gets the data for its zones across the network from another name server.

A. primary name server

B. secondary name server

C. ternary name server

D. primary name client


10) The process of obtaining zone information across the network is referred to as a .........

A. zone obtaining

B. zone transfer

C. zone information

D. zone extracting


11) Which of the following is/are the reasons to have secondary name servers within an enterprise network.

A. Redundancy

B. Remote locations

C. Load distribution

D. All of the above


12) The source of the zone information for a secondary name server is referred to as a ..........

A. Name server

B. Primary Name Server

C. Master Name Server

D. Secondary Name Server


13) In .......... , when a name server receives a DNS query that it cannot resolve through its own zone files, it sends a recursive query to its forwarder.

A. exclusive mode

B. non-exclusive mode

C. caching mode

D. zonal mode


14) Which of the following is not the work done by a name server using a forwarder in exclusive mode, when attempting to resolve a name.

A. Checks its local cache

B. Checks its zone files

C. Sends a recursive query to a forwarder

D. Attempts to resolve the name through iterative queries to other DNS servers.


15) In ..........., name servers rely on the name-resolving ability of the forwarders.

A. exclusive mode

B. non-exclusive mode

C. caching mode

D. zonal mode


16) Name servers in ........... make no attempt to resolve the query on their own if the forwarder is unable to satisfy the request.

A. exclusive mode

B. non-exclusive mode

C. caching mode

D. zonal mode


17) ........... are DNS servers that only perform queries, cache the answers, and return the results.

A. Querying only server

B. Results only server

C. Caching only server

D. Information only server


18) In DNS resource records, ............ indicate primary and secondary servers for the zone specified in the SOA resource record, and they indicate the servers for any delegated zones.

A. SOA records

B. A records

C. MX records

D. NS records


19) In DNS resource records,......... specifies a mail exchange server for a DNS domain name.

A. SRV

B. MX

C. PTR

D. NS


20) In DNS resource records, .......... specifies the IP addresses of servers of a specific service, protocol and DNS domain.

A. SRV

B. MX

C. PTR

D. NS


Answers:

1) C. Reverse queries
2) A. Positive caching
3) C. Negative Caching
4) C. Negative Caching
5) B. Time To Live
6) C. Both of the above
7) D. Round Robin Load Balancing
8) A. primary name server
9) B. secondary name server
10) B. zone transfer
11) D. All of the above
12) C. Master Name Server
13) B. non-exclusive mode
14) D. Attempts to resolve the name through iterative queries to other DNS servers.
15) A. exclusive mode
16) A. exclusive mode
17) C. Caching only server
18) D. NS records
19) B. MX
20) A. SRV


Related Posts:

For more MCQ's on Computer Networks: Click Here


Solved MCQ on Application Layer in OSI/TCP/IP Model set-2

Solved MCQ on Application Layer in OSI/TCP/IP Model set-2


1) In MIME header field, ............. is a world unique value identifying the content of this part of this message.

A. content-type

B. content-transfer-encoding

C. content-description

D. content-id


2) The Post Office Protocol, version 3, is a standard protocol with STD number 53 and it is described in .....

A. RFC 1939

B. RFC 0937

C. RFC 2821

D. RFC 2822


3) .............. is an electronic mail protocol with both client and server functions.

A. SMTP

B. MIME

C. POP

D. TCP


4) In authentication state of POP3 server, ............ is used to specify a mechanism by which both authentication and data protection can be provided.

A. USER

B. PASS

C. APOP

D. AUTH


5) In transaction state of POP3 commands, .......... retrieve the number of messages and total size of the messages.

A. STAT

B. LIST

C. RETR

D. DELE


6) A MIME compliant message must contain a header field with the ........ verbatim text.

A. MIME-version:1.0

B. MIME-version:1.1

C. MIME-version:2.0

D. MIME-version:2.1


7) In ......... name space, a name is assigned to an address. It is a sequence of characters without structure.

A. hierarchical

B. sequential

C. flat

D. addressed


8) The main disadvantage of a ......... name space is that it cannot be used in a large system such as the internet because it may be centrally controlled to avoid ambiguity and duplication.

A. hierarchical

B. sequential

C. flat

D. addressed


9) The ......... protocol defines a set of messages sent over either User Datagram Protocol(UDP) port53 or Transmission Control Protocol(TCP) port53.

A. Name space

B. DNS

C. Domain space

D. Zone transfer


10) Primary specifications for DNS are defined in which of the following Request for Comments(RFCs)?

A. 974

B. 1034

C. 1035

D. All of the above


11) Which of the following is/are the components of DNS defined by RFC 1034?

A. The domain namespace and resource records

B. Name servers

C. Resolvers

D. All of the above


12) ............ are records in the DNS database that can be used to configure the DNS database server or to contain information of different types of process client queries.

A. Domain namespace

B. Resource records

C. Name servers

D. Resolvers


13) ........... store resource records and information about the domain tree structure and attempt to resolve received client queries.

A. Domain namespace

B. DNS Names

C. Name servers

D. Resolvers


14) ............ are programs that run on DNS clients and DNS servers and that create queries to extract information from name servers.

A. Domain namespace

B. Resource records

C. Name servers

D. Resolvers


15) ........... have a very specific structure, which identifies the location of the name in the DNS namespace.

A. Domain namespace

B. DNS Names

C. Name servers

D. Resolvers


16) A ................... is a DNS domain name that has been constructed from its location relative to the root of the namespace is known as the root domain.

A. Fully Qualified Domain Name(FQDN)

B. Fully Structured Domain Name(FSDN)

C. Fully Constructed Domain Name(FCDN)

D. Fully Rooted Domain Name(FRDN)


17) State whether the following statements are True or False for the attributes of Fully Qualified Domain Name(FQDN).

i) FQDN are case-sensitive

ii) A period character separates each name.

iii) The entire FQDN can not be no more than 255 characters long.

A. i-True, ii-True, iii-False

B. i-True, ii-False, iii-True

C. i-False, ii-True, iii-True

D. i-False, ii-True, iii-False


18) A ...... is a contiguous portion of a domain of the DNS namespace whose database records exist and managed in a particular DNS database file stored on one or multiple DNS servers.

A. Subdomain

B. Zone

C. Sub DNS

D. Sub zone


19) In a/an ........... of DNS resolver, the queried name server is requested to respond with the requested data or with an error stating that data of the requested type or the specified domain name does not exist.

A. Recursive queries

B. Iterative queries

c. Reverse queries

D. Inverse queries


20) In MIME header field, ......... is a plain text description of the object within the body, which is useful when the object is not human-readable.

A. content-type

B. content-transfer-encoding

C. content-description

D.content-id

                                                                                                                                                                                                                Answers:

1) D. content-id
2) A. RFC 1939
3) C. POP
4) D. AUTH
5) A. STAT
6) A. MIME-version:1.0
7) C. flat
8) C. flat
9) B. DNS
10) D. All of the above
11) D. All of the above
12) B. Resource records
13) C. Name servers
14) D. Resolvers
15) B. DNS Names
16) A. Fully Qualified Domain Name(FQDN)
17) C. i-False, ii-True, iii-True
18) B. Zone 
19) A. Recursive queries
20) C. content-description


Related Posts:

For more MCQ's on Computer Networks: Click Here

MCQ Questions on Application Layer in OSI/TCP/IP Model set-1

MCQ Questions on Application Layer in OSI/TCP/IP Model set-1


1) Which of the following is/are the important applications of application layer?

A. Electronic mail

B. World Wide Web

C. USENET

D. All of the above


2) The TCP/IP ............. corresponds to the combined session, presentation, and application layers of the OSI model.

A. session layer

B. presentation layer

C. application layer

D. None of the above


3) The .......... protocol is based on end-to-end delivery.

A. SMTP

B. TCP

C. IP

D. SCTP


4) The well-known port of SMTP server is ........

A. 110

B. 25

C. 50

D. 20


5) In SMTP header field, ............. is a summary of the message being sent which is specified by the sender.

A. Reply-to

B. Return-path

C. Subject

D. From


6) In SMTP herder field, .......... is added by the final transport system that deilvers the mail.

A. Reply-to

B. Return-path

C. Subject

D. From


7) In SMTP mail transaction flow, the sender SMTP establishes a TCP connection with the destination SMTP and then waits for the server to send a ..........

A. 220 service ready message

B. 421 service not available message

C. Both of the above

D. None of the above


8) In SMTP mail transaction flow, .......... is sent, to which the receiver will identify itself by sending back its domain name.

A. HELO

B. MAIL FROM

C. RCPT TO

D. DATA


9) ............ is a command-line tool designed for most UNIX-like operating systems, which does not define a method of transferring mail, but rather acts as a client/server that supports multiple mail protocols.

A. Recieivemail

B. Sendmail

C. MIME

D. POP


10) Which of the following is/are the components of sendmail?

A. Mail user agent(MUA)

B. Mail transfer agent(MTA)

C. Mail delivery agent(MDA)

D. All of the above


11) The ............ is the interface through which a user can read and send mail.

A. Mail user agent(MUA)

B. Mail transfer agent(MTA)

C. Mail delivery agent(MDA)

D. Mail send agent(MSA)


12) The ............ acts like a mail router, accepting messages from both MTAs and MUAs.

A. Mail user agent(MUA)

B. Mail transfer agent(MTA)

C. Mail delivery agent(MDA)

D. Mail send agent(MSA)


13) .......... uses a queuing system to manage inbound and outbound mail.

A. Recieivemail

B. Sendmail

C. MIME

D. POP


14) The sender SMTP establishes a TCP connection with the destination SMTP and then waits for the server to send a ...... service ready message.

A. 421

B. 320

C. 220

D. 120


15) ............ is limited to 7-bit ASCII text, with a maximum line length of 1000 characters.

A. SMTP

B. MIME

C. POP

D. MTA


16) A ........... message is one which can be routed through any number of networks that are loosely compliant with RFC2821 or are capable of transmitting RFC2821 messages.

A. SMTP

B. MIME

C. POP

D. MTA


17) There are ....... number of standard content types in MIME.

A. 5

B. 7

C. 9

D. 4


18) In MIME header field, ......... describes how the object within the body is to be interpreted.

A. content-type

B. content-transfer-encoding

C. content-description

D. content-id


19) In MIME header field, ............ describes how the object within the body was encoded in order that it be included in the message using a mail-safe form.

A. content-type

B. content-transfer-encoding

C. content-description

D. content-id


20) In a/an ............ of DNS resolver, the queried name server can return the best answer it currently has back to the DNS resolver.

A. Recursive queries

B. Iterative queries

c. Reverse queries

D. Inverse queries

Answers:


1) D. All of the above
2) C. application layer
3) A. SMTP
4) B. 25
5) C. Subject
6) B. Return-path
7) C. Both of the above
8) A. HELO
9) B. Sendmail
10) D. All of the above
11) A. Mail user agent(MUA)
12) B. Mail transfer agent(MTA)
13) B. Sendmail
14) C. 220
15) A. SMTP
16) B. MIME
17) B. 7
18) A. content-type
19) B. content-transfer-encoding
20) B. Iterative queries



Related Posts:

For more MCQ's on Computer Networks: Click Here

Objective Questions on Transport Layer in OSI Model set-1

Objective Questions on Transport Layer in OSI Model set-1

                    
1) The .......... is responsible for end to end delivery, segmentation and concatenation.

A. Physical layer

B. Data Link layer

C. Network layer

D. Transport layer


2) .......... needs ports or service access points.

A. Physical layer

B. Data Link layer

C. Network layer

D. Transport layer


3) The task of ............... is to provide reliable, cost effective transport of data from source machine to destination machine.

A. Network Layer

B. Transport Layer

C. Presentation Layer

D. Application Layer


4) The hardware and/or software within the transport layer which does the work of making use of the services provided by the network layer is called as .........

A. transport media

B. transport device

C. transport entity

D. network transporter


5) .......... measures the number of bytes of user data transferred per second, measured over some time interval. It is measured separately for each direction.

A. Throughput

B. Transit delay

C. Protection

D. Resilience


6) ............ is the time between a message being sent by the transport user on the source machine and its being receive by the transport user on the destination machine.

A. Throughput

B. Transit delay

C. Protection

D. Resilience


7) The time difference between the instant at which a transport connection is requested and the instant at which it is confirmed is called as ........

A. Connection establishment delay

B. Transit delay

C. Protection delay

D. Priority delay


8) The message sent from transport entity to transport entity is called as ..........

A. transport data unit

B. transport display data unit

C. transport protocol data unit

D. transport protocol display unit


9) ........ are designed for the protocols like ICMP or OSPF, because these protocols are not use either stream packets or datagram sockets.

A. Berkeley sockets

B. Stream sockets

C. Datagram sockets

D. Raw sockets


10) .......... is designed for the connectionless protocol such as User Datagram Protocol(UDP).

A. Berkeley socket

B. Stream socket

C. Datagram socket

D. Raw socket


11) ............ is designed for the connection oriented protocol such as Transmission Control Protocol(TCP).

A. Berkeley socket

B. Stream socket

C. Datagram socket

D. Raw socket


12) ............ is used to implement the transport layer services between the two transport entities.

A. Transport service

B. Transport protocol

C. Transport address

D. Transport control


13) Which of the following is/are the tasks of transport protocols.

A. Error control

B. Sequencing

C. Flow control

D. All of the above


14) The internet uses universal port numbers for services and these numbers are called as .......

A. Well known port numbers

B. Fixed port numbers

C. Standard port numbers

D. Ephemeral port numbers


15) In the internet model, the client program defines itself with a port number which is chosen randomly. This number is called as .......

A. Well known port numbers

B. Fixed port numbers

C. Standard port numbers

D. Ephemeral port numbers


16) The port numbers ........... are known as well known ports and they are reserved for standard circuits.

A. below 1024

B. above 1024

C. below 2048

D. below 512


17) In the TCP segment header, .......... is a 32-bit number identifying the current position of the first data byte in the segment within the entire byte stream for the TCP connection.

A. serial number

B. current number

C. sequence number

D. acknowledgement number


18) In the TCP segment header, .......... is a 32-bit number identifying the next data byte the sender expects from the receiver.

A. serial number

B. current number

C. sequence number

D. acknowledgement number


19) A ........ is a special type of file handle, which is used by a process to request network services from the operating system.

A. socket

B. handler

C. requester

D. protocol


20) ........ is an optional 16-bit one's complement of the one's complement sum of a pseudo-IP header, the UDP header, and the UDP data.

A. Congestion

B. Checksum

C. Pseudosum

D. Headersum

Answers:


1) D. Transport layer
2) D. Transport layer
3) B. Transport Layer
4) C. transport entity
5) A. Throughput
6) B. Transit delay
7) A. Connection establishment delay
8) C. transport protocol data unit
9) D. Raw sockets
10) C. Datagram socket
11) B. Stream socket
12) B. Transport protocol
13) D. All of the above
14) A. Well known port numbers
15) D. Ephemeral port numbers  
16) A. below 1024
17) C. sequence number
18) D. acknowledgement number
19) A. socket
20) B. Checksum


Related Posts:

For more MCQ's on Computer Networks: Click Here

Kategori

Sport

Kategori